script default needs updating

View previous topic View next topic Go down

script default needs updating

Post by MetaPhaze on Thu Jan 23, 2014 10:21 am

I use the script named "default" in my persistent world.  The cep has taken over this script with the addition of their coins. Please take this into consideration and add

ExecuteScript(oPC, "default2");

or some such, at the end of default

Thanks

MetaPhaze

Posts : 6
Join date : 2014-01-22

View user profile

Back to top Go down

Re: script default needs updating

Post by MetaPhaze on Thu Jan 23, 2014 10:36 am

Actually I believe the fix would be more along the lines of this.

if(GetLocalInt(GetModule(), "CEP_I_USE_SCRIPT_DEFAULT") == 1)
    {
        ExecuteScript(oPC, "default2");
    }

MetaPhaze

Posts : 6
Join date : 2014-01-22

View user profile

Back to top Go down

Re: script default needs updating

Post by The Amethyst Dragon on Thu Feb 16, 2017 10:49 am

It looks like that script is in cep2_crp_s.hak. A remnant of old decision making that put scripts and blueprints into hak files (making them override scripting done in modules, like yours, and making such things much harder to change).

You can stop using that hak if you don't want it, or you can put your own version of "default" into a custom top hak or cep2_custom.hak.

If you want to keep using the C.R.A.P. systems from that hak, you could also extract all of the scripts and blueprint out of that hak, remove the hak from your module's custom content list, and import them into your module's resources.
avatar
The Amethyst Dragon
Custom Content Wyrm

Posts : 69
Join date : 2012-01-21
Age : 41
Location : lLoc = GetLocation(oDragon);

View user profile http://www.amethyst-dragon.com/nwn

Back to top Go down

Re: script default needs updating

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum